Prerequisites

  • Eclipse 4.4 (Luna) or higher
  • Java 1.8 or higher

Installing the plugin

  1. Install the plugin via the Eclipse Marketplace.
  2. Restart Eclipse when prompted.

Connecting your IDE to the Teamscale server

  1. Make sure Teamscale is properly installed. You should see a Teamscale menu entry in the main menu bar.
  2. Open the Eclipse Window -> Preferences menu and select Teamscale from the list.
  3. Use the "Add" button to add a new Teamscale serverĀ 
  4. Fill the dialog with the appropriate values. The IDE Requires you to use your IDE Access Key for authentication. You can find it under your user profile (located in the top right menu) and then clicking IDE Access Key.

  5. Click "Validate" to ensure successful connection the Teamscale server.

  6. Save and close the Preferences Dialog


Configuring your project

  1. Open the project properties (right click project -> Properties)
  2. Select the Teamscale menu entry
  3. Configure your Teamscale server, project and default branch. The default branch is used as fallback if it is not possible to determine the actual branch.

  4. Should your project's directory structure differ from the structure present on the server, create a mapping:

    1. Automatically
      To configure the prefixes automatically press Automatically configure Teamscale

    2. Manual
      If it is not possible to configure the prefixes automatically they have to be set manually:

      The Local Prefix is a part of your local directory structure.
      The Teamscale Prefix is a part of the project directory structure on the Teamscale server.
      Click Add to add a mapping. You can leave one of the entries empty, if you want to remove redundant parts of the local or server's path.

  5. Press OK


To check if everything is configured correctly, open the Findings View (Window -> Show View -> Other -> Teamscale -> Findings)


Now select any resource in the Project or Package Explorer that has findings and wait for findings to appear in the Findings View. The findings view will also refresh if you select an editor with a file that Teamscale has findings for. If findings don't show up, consider pressing the refresh button and if that doesn't help, restarting Eclipse before trying anything else.