Prerequisites

  • NetBeans 8.1 or higher
  • Java 1.8 or higher

Installing the plugin

  1. Start the NetBeans IDE.
  2. Open the Tools > Plugins dialog and switch to the Settings tab.
  3. Click Add and enter the following URL: https://www.cqse.eu/download/teamscale/ide/netbeans/latest/catalog.xml.gz
  4. Click OK and switch to the Available Plugins tab.
  5. Search for the Teamscale NetBeans Plugin, select it, and click Install.
  6. Accept the license terms and, when asked, dismiss the warning about the plugin being unsigned.

Connecting your IDE to the Teamscale server

  1. Open the Window > Services window.
  2. Select the Teamscale Servers node and select Add Server from the context menu.
  3. Fill the dialog with the appropriate values.
    • The Teamscale NetBeans Plugin requires you to use your IDE Access Key for authentication. If you have already filled in Server Name, URL, and Username, simply click Get Key and copy the key from the web page that opens.
    • Alternatively, log into your Teamscale server, open your user profile (located in the top right menu, and then click IDE Access Key. This takes you to the same web page.
  4. Click OK.

Configuring your project

  1. Open the Project Properties dialog by choosing Properties from the project’s context menu
  2. Open the Teamscale category
  3. Select the Enable Teamscale for this project checkbox
  4. Select your Teamscale server’s Server Name.
  5. Select the Project Name of the Teamscale project corresponding to your NetBeans project.
  6. Should your project’s directory structure differ from the structure present on the server, create a mapping:

    • To configure the prefixes automatically, select the Automatically create prefix mappings checkbox.

    • If it is not possible to configure the prefixes automatically, you will have to set them manually:

      1. Deselect the Automatically create prefix mappings checkbox.
      2. Click Add.
      3. The Local Prefix is a part of your local directory structure.

      4. The Teamscale Prefix is a part of the project directory structure on the Teamscale server.

      5. Click OK to add the mapping. You can leave one of the entries empty, if you want to remove redundant parts of the local or server’s path.

  7. Press OK

To check if everything is configured correctly, open the Findings​ window (Window > Teamscale > Findings). Now select any file or folder in the Projects​ window and wait for findings to appear in the Findings window.